Unexpected OVO Errors
Incident Report for Xendit
Resolved
We've detected that this issue has been resolved. The time of affected payments is between 00:48 - 01:07 WIB Nov 17th
Posted Nov 17, 2021 - 01:14 WIB
Investigating
Dear Customers,

We've detected errors with the OVO EWallets channel. We're currently monitoring and working with our channel partner to resolve.
Posted Nov 17, 2021 - 01:12 WIB
This incident affected: Indonesia - Payments (E-Wallets - OVO).