Disbursement & Remittance Disruption to PH BPI
Incident Report for Xendit
Resolved
This incident has been resolved.
Posted Jul 01, 2022 - 19:00 WIB
Investigating
Dear Customers,

We were informed that one of our destination channels are not able to receive disbursements.

Impact:

- PH_BPI disbursements more than P50,000 may intermittently fail
- Regional remittances to PH_BPI will not be processed
- PH_BPI disbursements less than P50,000 are not affected
- All other disbursements are not affected

We deeply apologize for the inconvenience and the sudden announcement. If you need further assistance, please contact us at help@xendit.ph

Thank you for your understanding and cooperation.

Regards,
Xendit Customer Support
Posted Jul 01, 2022 - 11:31 WIB