Mandiri disbursement disruption
Incident Report for Xendit
Resolved
We identified and resolved the intermittent issue from our partner's end. Disbursements to Mandiri and Mandiri SYR are now operational.
Posted Mar 05, 2021 - 17:31 WIB
Investigating
Dear Customers,

We identified an issue with disbursements to Mandiri and Mandiri SYR bank accounts. We are currently investigating the issue.

We apologize for any inconvenience caused. Thank you for your understanding and patience.

Kind regards,
Xendit Customer Support
Posted Mar 05, 2021 - 16:30 WIB
This incident affected: Callback (Disbursements).