Disbursement & Remittance Disruption to PH BPI and PH BDO
Incident Report for Xendit
Resolved
This incident has been resolved.
Posted Jun 30, 2022 - 20:41 WIB
Investigating
Dear Customers,

We were informed that two of our destination channels are not able to receive disbursements.

Impact:

- PH BPI and PH BDO disbursements less than Php100,000,000 will not be processed.
- Regional remittances to PH BPI and PH BDO will not be processed as well

We deeply apologize for the inconvenience and the sudden announcement. If you need further assistance, please contact us at help@xendit.ph

Thank you for your understanding and cooperation.

Regards,
Xendit Customer Support
Posted Jun 30, 2022 - 17:07 WIB
This incident affected: Philippines - Payouts (Disbursement - BDO).