Degraded performance for IDR disbursements
Incident Report for Xendit
Resolved
This incident has been resolved
Posted Aug 17, 2022 - 13:23 WIB
Investigating
Dear customers

We are currently observing slow processing for IDR disbursements

Impact:
Some IDR disbursements, IDR remittance, withdrawal, and batch disbursements, Escrow will be processed slower than usual

We are currently investigating the issue.
Sorry for the inconvenience caused

Thank you for your patience.
Posted Aug 17, 2022 - 13:16 WIB
This incident affected: Indonesia - Payouts (Disbursement - BCA, Disbursement - BRI, Disbursement - BNI) and Dashboard (Batch Disbursements).