PH Banco De Oro - Disbursement Disruption
Incident Report for Xendit
Resolved
Our service monitor has detected that partner service has been back online since 2001hrs (UTC+8).
Posted Jan 16, 2023 - 20:20 WIB
Investigating
Dear customers

We have detected issues in the following services:

PH Bank Banco De Oro - Disbursement
All Disbursement (including regional remittance and withdrawal) to PH BDO will be delayed.

We are currently in the process of investigating and will keep this page updated as we learn more and restore these services.
Posted Jan 16, 2023 - 17:43 WIB
This incident affected: Disbursement (BDO).