Cards Payment Partial Disruption

Incident Report for Xendit

Resolved

This incident has been resolved.
Posted Nov 13, 2023 - 13:12 WIB

Investigating

Dear valued customers,

We detected a partial disruption on cards payment from one of our acquirer in the Philippines.

We have identified the root cause and currently fixing this with our acquiring partner.

Thank you for your understanding.
Posted Nov 13, 2023 - 12:33 WIB
This incident affected: Credit/Debit Cards (Credit/Debit Cards).