We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: 1-9999, above 100000001
Posted Feb 07, 2025 - 04:40 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: above 250000001
Posted Feb 07, 2025 - 04:30 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: 1-9999, above 100000001
Posted Feb 07, 2025 - 04:20 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: above 250000001
Posted Feb 07, 2025 - 04:00 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: All amount MANDIRI: above 250000001
Posted Feb 06, 2025 - 23:00 WIB
This incident affected: Indonesia - Payouts (Disbursement - BNI, Disbursement - Other Indonesia banks and E-Wallets) and Remittance Payouts.