Balance History Report Disruption
Incident Report for Xendit
Resolved
We have resolved the issue. You should have received your report by now. We are sorry for the inconvenience
Posted Aug 01, 2024 - 12:12 WIB
Investigating
Dear customers,

We have detected a disruption on balance history report generation. You may face delay in receiving the report. We are investigating.
Posted Aug 01, 2024 - 10:12 WIB