We are currently seeing delays in processing Payouts, Disbursements to the following PHP destinations due to system issues with our partner.
PH_UBP: above 50001 Other banks and Ewallets: 1-50000
Posted Sep 19, 2024 - 14:20 WIB
Update
Dear valued costumers,
We are currently seeing delays in processing Remittance, Payouts, Disbursements to the following PHP destinations due to system issues with our partner.
PH_BDO: 1-50000 PH_BPI: 1-50000 PH_PAYMAYA: 1-50000 PH_UBP: All amount Other banks and Ewallets: 1-50000
Posted Sep 19, 2024 - 14:00 WIB
Identified
Dear valued costumers,
We are currently seeing delays in processing Payouts, Disbursements to the following PHP destinations due to system issues with our partner.
PH_UBP: above 50001 Other banks and Ewallets: 1-50000
Posted Sep 19, 2024 - 12:50 WIB
This incident affected: Philippines - Payouts (Disbursement - Other Philippines banks and E-Wallets) and Remittance Payouts.