The Philippines Disbursement, Withdrawal, and Remittance Disruption
Incident Report for Xendit
Resolved
This incident has been resolved.
Posted Jan 24, 2023 - 08:22 WIB
Identified
Dear Customers,

We are currently facing issue with UBP as our bank partner
We already identified the issue and working on the fix with the partner.

Impact:
- Remittance with amount PHP less than or equal 50K PHP will be delayed and kept in PENDING
- Remittance with amount PHP more than 50K PHP is not affected
- There might be a slight delay for The Philippines disbursements and withdrawals with amount less than 50k

We deeply apologize for the inconvenience and the sudden announcement. If you need further assistance, please contact us at help@xendit.ph

Thank you for your understanding and cooperation.

Regards,
Xendit Customer Support
Posted Jan 23, 2023 - 13:55 WIB
This incident affected: Disbursement (Philippines Banks & Ewallets).