We are currently seeing delays in processing Payouts, Disbursements, Remittance to the following PHP destinations due to system issues with our partner.
PH_BDO: 1-50000 PH_BPI: 1-50000 PH_GCASH: 1-50000 PH_PAYMAYA: 1-50000 PH_UBP: All amount Other banks and Ewallets: 1-50000
Posted Mar 27, 2025 - 12:40 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements to the following PHP destinations due to system issues with our partner.
PH_BDO: 1-50000 PH_GCASH: 1-50000 PH_PAYMAYA: 1-50000 PH_UBP: All amount Other banks and Ewallets: 1-50000
Posted Mar 27, 2025 - 12:10 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements, Remittance to the following PHP destinations due to system issues with our partner.
PH_BDO: 1-50000 PH_GCASH: 1-50000 PH_PAYMAYA: 1-50000 PH_UBP: All amount Other banks and Ewallets: 1-50000
Posted Mar 27, 2025 - 12:00 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements to the following PHP destinations due to system issues with our partner.
PH_GCASH: 1-50000
Posted Mar 27, 2025 - 11:50 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements to the following PHP destinations due to system issues with our partner.
PH_BDO: 1-50000 PH_GCASH: 1-50000 PH_PAYMAYA: 1-50000 PH_UBP: 1-50000 Other banks and Ewallets: 1-50000
Posted Mar 27, 2025 - 11:40 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements to the following PHP destinations due to system issues with our partner.
PH_GCASH: 1-50000
Posted Mar 27, 2025 - 11:30 WIB
Identified
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements to the following PHP destinations due to system issues with our partner.
PH_BDO: 1-50000 PH_GCASH: 1-50000 PH_PAYMAYA: 1-50000 PH_UBP: All amount Other banks and Ewallets: 1-50000
Posted Mar 27, 2025 - 10:40 WIB
This incident affected: Philippines - Payouts (Disbursement - BDO, Disbursement - GCASH, Disbursement - Paymaya, Disbursement - Other Philippines banks and E-Wallets) and Remittance Payouts.