Disruption with option to pay using GCash Bill Repayment
Incident Report for Xendit
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 19:15 WIB
Monitoring
Dear customers,
We have been informed of a disruption to ECPay and ECPayLoan by our partners via GCash Biller options. Customers can still pay through Maya Biller options.

Please
Posted Apr 23, 2024 - 12:02 WIB
This incident affected: Philippines - Payments (Over-The-Counter Payments - ECPay, Over-The-Counter Payments - ECPay Loans, Over-The-Counter Payments - ECPay School).