Over-The-Counter ECPAY_SCHOOL Philippines Disruption
Incident Report for Xendit
Resolved
Dear Customers,

This incident has been resolved.

Sincerely,
Xendit customer service
Posted Dec 03, 2024 - 19:07 WIB
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 03, 2024 - 17:16 WIB
This incident affected: Philippines - Payments (Over-The-Counter Payments - ECPay School).