Remittance Disruption

Incident Report for Xendit

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 21:16 WIB

Identified

Dear Valued Customers,

We have detected issues with remittance transactions due to disruption on our partner's end. Your transaction completion will be delayed. We're working closely with our partner to resolve this issue

Sorry for the inconvenience caused.

Sincerely,
Xendit customer service
Posted Jan 29, 2026 - 20:37 WIB
This incident affected: Global Payouts (Global Payouts - EUR, Global Payouts - GBP, Global Payouts - MYR) and Remittance Payouts.