Dana Callbacks Delayed
Incident Report for Xendit
Resolved
We have received confirmation from Dana that callbacks are no longer delayed and we've confirmed that on our end as well. If you are experiencing any delayed Dana callbacks, please escalate to CS and we will be able to help you identify and resolve any remaining issues
Posted Feb 23, 2021 - 10:32 WIB
Identified
Starting from 6AM WIB, we have started to receive delayed callbacks from Dana for payments made last night
Posted Feb 23, 2021 - 10:20 WIB
Investigating
Dear customers,

We've been informed by our channel partner that Dana callbacks are currently delayed. We will update you with progress once we learn about it.
Posted Feb 23, 2021 - 09:48 WIB
This incident affected: Callback (eWallets).