Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 20, 2026 - 22:30 WIB
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 18, 2026 - 12:55 WIB
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 18, 2026 - 12:35 WIB
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 18, 2026 - 12:34 WIB
Update
Dear Valued Customers,
Please be informed that our partner bank will be conducting scheduled maintenance as part of their system enhancement activities.
Maintenance Schedule: Start Time: June 20 2026, 11:30 PM (GMT+8) Estimated End Time: June 21, 03:30 AM (GMT+8)
Affected Services: Card Payments: Users may experience issues with certain card transactions during the maintenance window
We apologize for any inconvenience this may cause and appreciate your patience and understanding during this maintenance period. If you need further assistance, please contact us at help@xendit.ph
Best regards,
Posted Jun 20, 2026 - 22:30 WIB
Update
Dear Valued Customers,
Please be informed that our partner bank will be conducting scheduled maintenance as part of their system enhancement activities.
Maintenance Schedule: Start Time: June 20 2026, 11:30 PM (GMT+8) Estimated End Time: June 21, 03:30 AM (GMT+8)
Affected Services: Card Payments: Users may experience issues with certain card transactions during the maintenance window
We apologize for any inconvenience this may cause and appreciate your patience and understanding during this maintenance period. If you need further assistance, please contact us at help@xendit.ph
Best regards,
Posted Jun 20, 2026 - 22:30 WIB
Scheduled
Dear Valued Customers,
Please be informed that our partner bank will be conducting scheduled maintenance as part of their system enhancement activities.
Maintenance Schedule: Start Time: June 20 2026, 11:30 PM (GMT+8) Estimated End Time: June 21, 03:30 AM (GMT+8)
Affected Services: Card Payments: Users may experience issues with certain card transactions during the maintenance window
We apologize for any inconvenience this may cause and appreciate your patience and understanding during this maintenance period. If you need further assistance, please contact us at help@xendit.ph
Best regards,
Posted Jun 17, 2026 - 21:19 WIB
This scheduled maintenance affected: Philippines - Payments (Credit/Debit Cards).