Issue with transactions for Third Party Integrations

Incident Report for Xendit

Resolved

Dear Customers,

We recently saw issues with some of our third party integrations. Specifically Wix, Xero and Ecwid.
Customers would not have been able to checkout & receive responses from us for these channels.

Time of issue:
- 12:47 to 14:13 GMT+8

Please use the dashboard to check the status of transactions or contact our customer support if you have further issues.

Xendit Team
Posted Dec 08, 2025 - 14:02 WIB