We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: 1-9999, above 100000001
Posted Feb 22, 2025 - 04:20 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: All amount
Posted Feb 22, 2025 - 04:10 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: above 250000001
Posted Feb 22, 2025 - 04:00 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: 1-9999, above 100000001
Posted Feb 22, 2025 - 01:00 WIB
Identified
Dear valued customers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: All amount
Posted Feb 21, 2025 - 23:00 WIB
This incident affected: Indonesia - Payouts (Disbursement - BNI, Disbursement - Other Indonesia banks and E-Wallets) and Remittance Payouts.