Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 10, 2026 - 23:00 WIB
Scheduled
Dear Valued Customers,
In order to improve service quality, please be informed that Bank BJB will be conducting a scheduled maintenance on:
Start Date: Fri Jul 10 2026 23:00:00 GMT+7 End Date: Sat Jul 11 2026 01:00:00 GMT+7
During this period, the following services will be temporarily unavailable:
- BJB Virtual Account payments via BJB channels (BJB Mobile, BJB ATM, and BJB Corporate Internet Banking) - Real-Time Online Transfers (RTOL) from other banks to BJB
We kindly advise you to complete any transactions outside of the maintenance window to avoid disruptions.
We apologize for any inconvenience caused and appreciate your understanding.
If you need further assistance, please feel free to reach out to our support team.
Best regards,
Posted Jul 10, 2026 - 15:23 WIB
This scheduled maintenance affects: Indonesia - Payments (Virtual Account - BJB).