The Philippines Disbursement, Withdrawal, and Remittance Disruption
Incident Report for Xendit
Resolved
Dear Customers,

The issue with partner already resolved.
The operation back to normal.

Thank you for your understanding and cooperation.

Regards,
Xendit Customer Support
Posted Jan 20, 2023 - 16:42 WIB
Identified
Dear Customers,

We are currently facing issue with UBP as our bank partner
We already identified the issue and working on the fix with the partner.

Impact:
- Remittance with amount PHP
- Remittance with amount PHP > 50k is not affected
- There might be a slight delay for The Philippines disbursements and withdrawals with amount < 50k

We deeply apologize for the inconvenience and the sudden announcement. If you need further assistance, please contact us at help@xendit.ph

Thank you for your understanding and cooperation.

Regards,
Xendit Customer Support
Posted Jan 20, 2023 - 16:03 WIB
This incident affected: Philippines - Payouts (Disbursement - Other Philippines banks and E-Wallets).