We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: 1-250000000 BRI: 10000-100000000 Other banks and Ewallets: 1-250000000
Posted Nov 19, 2024 - 00:10 WIB
Update
Dear valued costumers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: 1-250000000 BRI: 10000-100000000 MANDIRI: 1-250000000 Other banks and Ewallets: 1-250000000
Posted Nov 18, 2024 - 23:40 WIB
Update
Dear valued costumers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BNI: 1-250000000 MANDIRI: 1-250000000 Other banks and Ewallets: 1-250000000
Posted Nov 18, 2024 - 23:03 WIB
Update
Dear valued costumers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to IDR destinations with amount 1-4999 except for BCA, BNI, BRI, MANDIRI, PERMATA due to system issues with our partner.
Posted Nov 18, 2024 - 22:20 WIB
Update
Dear valued costumers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BCA: 1-4999 Other banks and Ewallets: 1-4999
Posted Nov 18, 2024 - 22:10 WIB
Update
Dear valued costumers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to IDR destinations with amount 1-4999 except for BCA, BNI, BRI, MANDIRI, PERMATA due to system issues with our partner.
Posted Nov 18, 2024 - 22:00 WIB
Identified
Dear valued costumers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
BCA: 1-4999 Other banks and Ewallets: 1-4999
Posted Nov 18, 2024 - 20:20 WIB
This incident affected: Indonesia - Payouts (Disbursement - BRI, Disbursement - BNI, Disbursement - BSI, Disbursement - Other Indonesia banks and E-Wallets) and Remittance Payouts.