Delayed Processing in PH Disbursements, Remittances and Withdrawals
Incident Report for Xendit
Resolved
The issue has been resolved.
Thank you for your understanding and cooperation.
Posted Mar 15, 2023 - 15:46 WIB
Monitoring
We have received a notice from our partner that the issue has been resolved. We will continue monitoring.
Posted Mar 15, 2023 - 15:39 WIB
Update
We are continuing to investigate this issue.
Posted Mar 15, 2023 - 14:48 WIB
Update
We are continuing to investigate this issue.
Posted Mar 15, 2023 - 14:48 WIB
Investigating
Dear Valued Customers,

We are detecting delayed disbursements to Philippines destinations.

Impact:
- All disbursements, withdrawals, and remittances with amount less than or equal to PHP 50,000 will be delayed until issue is resolved.
- No impact for transactions with amount more than PHP 50,000.

We are working with our partners to investigate the issue, and will share more details when we have one.

Please refrain from transacting with amounts less than or equal to 50k PHP in the meantime. There is no impact to transaction of more than 50k PHP.

We deeply apologize for the inconvenience and the sudden announcement.

If you need further assistance, please contact us at help@xendit.ph.

Thank you for your understanding and cooperation.
Posted Mar 15, 2023 - 11:12 WIB
This incident affected: Dashboard (Dashboard Withdrawals, Autowithdrawal) and Philippines - Payouts (Disbursement - Other Philippines banks and E-Wallets).