[PH Disbursement] Delayed Disbursement through GCash

Incident Report for Xendit

Resolved

This incident has been resolved.
Posted Jun 30, 2025 - 08:07 WIB

Investigating

Dear Customers,

We are seeing a higher number of error responses from our partner GCash through our disbursement rail.

Impact: Customers will see an increase in the number of pending disbursements when made through the GCash.

We will reconcile the transactions after verifying the status of the transactions with the partner.

Best Regards,
Xendit Team
Posted Jun 28, 2025 - 10:28 WIB
This incident affected: Philippines - Payouts (Disbursement - GCASH).