PH Disbursements & Remittance Disruption
Incident Report for Xendit
Resolved
We've observed that disbursements and remittance performance has returned to normal
Posted May 31, 2023 - 11:58 WIB
Investigating
Dear customers,

We are experiencing delays in our disbursements and remittance performance in PH. We expect the impact to be:

1. Remittance with amount
2. Remittance with amount > 50k is not affected
3. There will be a delay for PH disbursements and withdrawals with amount

We will continue to monitor and update with progress.
Posted May 31, 2023 - 11:07 WIB
This incident affected: Philippines - Payouts (Disbursement - Other Philippines banks and E-Wallets).