Disruption to Disbursements
Incident Report for Xendit
Resolved
The incident has been resolved.
All delayed disbursements have been processed. We thank you for your patience
Posted Jul 12, 2020 - 11:57 WIB
Monitoring
Disbursements has been operating again normally and we are actively monitoring the progress to ensure all delayed disbursements will be processed
Posted Jul 12, 2020 - 11:34 WIB
Investigating
Dear Customer,
We have identified disbursements delay to BNI, BRI, and MANDIRI recipients
We are working together with our bank partners to resolve this issue as soon as possible
Posted Jul 12, 2020 - 11:22 WIB
This incident affected: API (xenDisburse).