Over-The-Counter SEVEN_ELEVEN Philippines Disruption
Incident Report for Xendit
Resolved
Dear Customers,

This incident has been resolved.

Sincerely,
Xendit customer service
Posted Sep 10, 2024 - 01:47 WIB
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 10, 2024 - 01:21 WIB
This incident affected: Philippines - Payments (Over-The-Counter Payments - 7-Eleven).