Disbursements Disruption
Incident Report for Xendit
Resolved
This incident has been resolved.
Posted Sep 07, 2021 - 18:36 WIB
Investigating
Dear Customers,

We are currently experiencing issues with our disbursement partner.

Impact:

All disbursements to BNI, BRI, Mandiri are not affected.
Disbursements to other banks with amounts up to IDR 25,000,000 are not affected
Disbursements to other banks with amounts from IDR 25,000,000 to IDR 100,000,000 will be kept pending in our system until the issue is resolved.

Sincerely,
Xendit Customer Support
Posted Sep 07, 2021 - 18:25 WIB
This incident affected: Callback (Disbursements).