DIRECT_DEBIT PESONET_ONLINE_BANKING Philippines Disruption

Incident Report for Xendit

Resolved

Dear Customers,

This incident has been resolved.

Sincerely,
Xendit customer service
Posted Mar 22, 2025 - 13:42 WIB

Identified

Dear Valued Customers,

We have detected issues with DIRECT_DEBIT PESONET_ONLINE_BANKING payments due to disruption on our partner's end.



Sorry for the inconvenience caused.

Sincerely,
Xendit customer service
Posted Mar 21, 2025 - 16:12 WIB
This incident affected: Philippines - Payments (Direct Debit - Pesonet Online Banking).