Over-The-Counter ECPAY_SCHOOL Philippines Disruption

Incident Report for Xendit

Resolved

Dear Customers,

This incident has been resolved.

Sincerely,
Xendit customer service
Posted Apr 21, 2025 - 14:18 WIB

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 21, 2025 - 08:54 WIB
This incident affected: Philippines - Payments (Over-The-Counter Payments - ECPay School).