QRPH Payment Dirstruption

Incident Report for Xendit

Resolved

This incident has been resolved.
Posted Oct 11, 2025 - 17:16 WIB

Monitoring

Our partner has reported resumption of service. We shall continue to monitor.
Posted Oct 11, 2025 - 16:06 WIB

Update

Our partner confirmed that the issue is only impacting QRPH via GCash. GCash is currently under maintenance.

"ADVISORY: Pay QR via QRPH will be right back! We are working to restore the service as soon as possible."
https://help.gcash.com/hc/en-us/sections/22717320336281-GCash-Advisories
Posted Oct 11, 2025 - 15:40 WIB

Identified

Our partner has identified the issue. We shall relay the update accordingly.
Posted Oct 11, 2025 - 12:35 WIB

Investigating

We saw a drop in QRPH Payment completion from 10:34 GMT +8

Customers may not receive successful QRPH callback

We are still investigating and reaching out to our partner
Posted Oct 11, 2025 - 10:43 WIB
This incident affected: Philippines - Payments (QR Payments - QRPH).