Payout disruption

Incident Report for Xendit

Resolved

This incident has been resolved.
Posted May 25, 2023 - 07:56 WIB

Identified

Dear Customers,

We are currently seeing a disruption with our payouts product and we are seeing some delays in disbursement speed.

Impact:
- Intermittent delays in disbursements
- Some disbursements will be stuck in PENDING status

We apologize for any inconvenience caused and are working to fix this as soon as possible.

Sincerely,
Xendit customer success
Posted May 25, 2023 - 07:17 WIB
This incident affected: Callback (Payouts).