[BPI - Unscheduled Downtime]

Incident Report for Xendit

Resolved

This incident has been resolved.
Posted Jun 15, 2026 - 11:22 WIB

Investigating

Dear Valued Merchant, BPI just reported an ongoing unplanned service interruption affecting partner transactions.

Restoration efforts are underway, with a tentative recovery target of 4pm PH time 14 June 2026. We'll keep this thread updated as soon as new information is available.

Thank you
Posted Jun 15, 2026 - 04:47 WIB
This incident affected: Philippines - Payouts (Disbursement - BPI) and Philippines - Payments (Direct Debit - BPI, Direct Debit - BPI Online Banking, Direct Debit - BPI Recurring).