Delayed Payouts / Disbursement Processing

Incident Report for Xendit

Resolved

Dear Valued Customers,

This issue has been resolved.

We deeply apologize for the inconvenience.

Sincerely,
Xendit Customer Support
Posted Nov 29, 2023 - 16:59 WIB

Identified

Dear Valued Customers,

We are currently seeing delays in processing payouts to PH destinations due to system issues with our partner.

Impact:
- Processing of Some Payouts, Remittance and Withdrawals with amount

We deeply apologize for the inconvenience.

Sincerely,
Xendit Customer Support
Posted Nov 29, 2023 - 16:05 WIB
This incident affected: Philippines - Payouts (Disbursement - BDO, Disbursement - BPI, Disbursement - GCASH, Disbursement - Paymaya, Disbursement - Other Philippines banks and E-Wallets, Batch Payout).