Payouts Disruption in Indonesia
Incident Report for Xendit
Resolved
This incident has been resolved.
Posted Feb 03, 2024 - 09:00 WIB
Update
Dear valued costumers,

We are currently seeing delays in processing Disbursements, Remittance, Escrow to IDR destinations except for BCA, BNI, BRI, MANDIRI, PERMATA due to system issues with our partner.
Posted Feb 03, 2024 - 08:50 WIB
Update
Dear valued costumers,

We are currently seeing delays in processing Disbursements, Remittance, Escrow, Payouts to IDR destinations except for BCA, BNI, BRI, MANDIRI, PERMATA due to system issues with our partner.
Posted Feb 03, 2024 - 08:40 WIB
Identified
Dear valued costumers,

We are currently seeing delays in processing Disbursements, Remittance, Escrow to IDR destinations except for BCA, BNI, BRI, MANDIRI, PERMATA due to system issues with our partner.
Posted Feb 03, 2024 - 08:20 WIB
This incident affected: Indonesia - Payouts (Disbursement - Other Indonesia banks and E-Wallets) and Remittance Payouts.