UBP Disbursements Disruption
Incident Report for Xendit
Resolved
We've confirmed that this maintenance has concluded at 6AM GMT+8
Posted Mar 06, 2023 - 08:16 WIB
Monitoring
Maintenance has been extended to March 6th 2AM GMT+8. We are working with the partner to monitor the health of this channel.
Posted Mar 05, 2023 - 23:59 WIB
Investigating
Dear Customers,

We have just confirmed that UBP is having emergency maintenance from 15:40 PM - 23:59 GMT+8. The impact is

1. All PHP disbursements will be delayed in processing
2. All PHP withdrawals will be delayed in processing
3. All PHP regional remittance payouts in pending
Posted Mar 05, 2023 - 14:59 WIB
This incident affected: Philippines - Payouts (Disbursement - Other Philippines banks and E-Wallets).