VA Payment Callback Disruption
Incident Report for Xendit
Resolved
This incident has been resolved.
Posted Jun 30, 2022 - 22:08 WIB
Investigating
Dear Customers,

We are currently facing an issue with VA Payment Callback and you might experience some delays.

Impact:

- Payment Callback would be delayed

We deeply apologize for the inconvenience and the sudden announcement. If you need further assistance, please contact us at help@xendit.ph

Thank you for your understanding and cooperation.

Regards,
Xendit Customer Support
Posted Jun 30, 2022 - 21:21 WIB
This incident affected: Callback (Virtual Accounts).