DIRECT_DEBIT UBP Philippines Disruption
Incident Report for Xendit
Resolved
Dear Customers,

This incident has been resolved.

Sincerely,
Xendit customer service
Posted Mar 26, 2024 - 16:59 WIB
Identified
Dear Valued Customers,

We have detected issues with DIRECT_DEBIT UBP payments due to disruption on our partner's end.

Impact:
- We are seeing issues with completion of payments.

We are investigating and will keep this page updated as we hear news from our partner.

In the meantime, we recommend that you take the following actions to mitigate disruption during this incident:
- Customers may use other payment methods in the meantime.
- It is recommended to wait for the channel to stabilize before retrying the transaction.
- If a customer encounters any failed transactions but were debited, a reversal will be processed within the next 5 business days.



Sorry for the inconvenience caused.

Sincerely,
Xendit customer service
Posted Mar 26, 2024 - 16:43 WIB
This incident affected: Philippines - Payments (Direct Debit - Unionbank).