Payouts Disruption in Indonesia
Incident Report for Xendit
Resolved
This incident has been resolved.
Posted Mar 23, 2024 - 08:10 WIB
Identified
Dear valued costumers,

We are currently seeing delays in processing Disbursements, Remittance, Escrow to IDR destinations except for BCA, BNI, BRI, MANDIRI, PERMATA due to system issues with our partner.
Posted Mar 23, 2024 - 08:02 WIB
This incident affected: Indonesia - Payouts (Disbursement - BSI, Disbursement - Other Indonesia banks and E-Wallets) and Remittance Payouts.