Dashboard Payouts

Scheduled for May 20, 04:30 - 06:30 WIB

Update

We will be undergoing scheduled maintenance during this time.
Posted May 13, 2026 - 17:28 WIB

Scheduled

Dear Valued Customer,

Please be informed that cross-border payouts in THB, MYR, USD, AUD, CNY, EUR, KRW, and GBP will be temporarily unavailable during the scheduled maintenance period.

Maintenance Window: 20th May 2026, 9:30 PM – 11:30 PM GMT

Kindly note that all payout requests submitted via the dashboard during this time will only be processed once the maintenance window has ended.

We highly recommend:
• Avoid sending transactions during the maintenance window
• Queue transactions for submission after services are restored

We apologize for any inconvenience this may cause and appreciate your understanding.

Sincerely,
Xendit
Posted May 13, 2026 - 17:26 WIB
This scheduled maintenance affects: Global Payouts (Global Payouts - EUR, Global Payouts - GBP, Global Payouts - MYR).