Payouts Disruption in Indonesia

Incident Report for Xendit

Resolved

This incident has been resolved.
Posted Feb 15, 2024 - 12:04 WIB

Identified

Dear valued costumers,

We are currently seeing delays in processing Disbursements, Remittance, Escrow to IDR destinations except for BCA, BNI, BRI, MANDIRI, PERMATA due to system issues with our partner.
Posted Feb 15, 2024 - 11:50 WIB
This incident affected: Indonesia - Payouts (Disbursement - BSI, Disbursement - Other Indonesia banks and E-Wallets) and Remittance Payouts.