Disruption on API and Dashboard

Incident Report for Xendit

Resolved

Our partner has managed to resolve this incident at 2:28 AM GTM+7. This incident has been resolved
Posted Nov 19, 2025 - 03:54 WIB

Monitoring

A mitigation has been deployed by our partner. They are working on recover the services

https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 21:18 WIB

Identified

Dear Valued Customers,

Our partner, Cloudflare has acknowledged the issue of their global outage. We’re working closely with them to solve this issue

https://www.cloudflarestatus.com/

Regards,
Xendit Customer Service
Posted Nov 18, 2025 - 18:56 WIB

Investigating

Dear customers,

We are experiencing several connectivity issues to Xendit Dashboard, Checkout page, and API when receiving a request from server and client located in South East Asia, due to an issue with our network partner, Cloudflare.

We're currently working with our network partner to resolve the issue

We apologize for inconvenience and we will share more update when we have one

Regards,
Xendit Customer Service
Posted Nov 18, 2025 - 18:49 WIB
This incident affected: Dashboard (Dashboard, Dashboard Withdrawals, Onboarding, Autowithdrawal, Batch Disbursements, Payment Links), API (Cards, Customers Endpoints, Direct Debit, E-Wallets, Over-The-Counter Payments, PayLater, Payment APIs, Payment Links, Payouts, QR Codes, Subscriptions, Virtual Account, xenPlatform Accounts, xenPlatform Transfers), and Third Party Integrations (e.g. Shopify, WooCommerce etc.).