Issues With Registration
Incident Report for Xendit
Resolved
Dear Valued Customers,

The issue has been resolved. Thank you for your understanding and patience.

Kind regards,
Xendit Customer Support
Posted Jan 07, 2021 - 06:32 WIB
Investigating
Dear Valued Customers,

We are experiencing issues with registration where you cannot register any new account.

Our team is investigating and we apologize for any inconvenience caused. Thank you for your understanding and patience.

Kind regards,
Xendit Customer Support
Posted Jan 07, 2021 - 05:57 WIB