Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 22, 2025 - 03:00 WIB
Scheduled
Dear Valued Customers,
We were informed that OVO payment options will be unavailable on
Date: Tuesday, 22 April 2025 Time: 03:00 to 05:30 AM (GMT+7) Duration: 2 hours 30 minutes
due to scheduled System Maintenance. During this time, end users will be unable to access their OVO to complete transactions.
Please refrain from transacting using OVO during the maintenance window above, as the partner's service and application will be temporarily unavailable.
We deeply apologize for the inconvenience. If you need further assistance, please contact us at help@xendit.co
Thank you for your understanding and cooperation.
Regards, Xendit Customer Support
Posted Apr 18, 2025 - 07:44 WIB
This scheduled maintenance affected: Indonesia - Payments (E-Wallets - OVO).