We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
MANDIRI: above 250000001
Posted Mar 27, 2025 - 03:40 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Payouts, Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
MANDIRI: above 250000001
Posted Mar 27, 2025 - 03:10 WIB
Update
Dear valued customers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
MANDIRI: 1-9999, above 50000001
Posted Mar 27, 2025 - 03:00 WIB
Identified
Dear valued customers,
We are currently seeing delays in processing Disbursements, Remittance, Escrow to the following IDR destinations due to system issues with our partner.
MANDIRI: above 250000001
Posted Mar 26, 2025 - 23:00 WIB
This incident affected: Indonesia - Payouts (Disbursement - Other Indonesia banks and E-Wallets) and Remittance Payouts.