Website Inaccessible

Incident Report for Xendit

Resolved

This incident has been resolved.
Posted Aug 24, 2026 - 09:32 WIB

Investigating

Dear Customers,

We have identified an issue with our landing website.
Merchant Dashboard and Docs are not affected.

We are working to restore access to the website shortly.

Best Regards,
Xendit Customer Service
Posted Aug 24, 2026 - 08:45 WIB