Disbursement Bank Disruption - PH BPI
Incident Report for Xendit
Resolved
This incident has been resolved.
Posted Jun 20, 2022 - 09:33 WIB
Identified
Dear Valued Customers,

We were informed that Disbursements and Remittance to PH_BPI are currently unavailable due to the destination bank's internal error.

Impact:
BPI disbursements will be stuck in PENDING status
Regional remittances to BPI are also affected.

Please refrain from transacting to these destination channels in the meantime.
We sincerely apologize for the inconvenience and the sudden announcement.
If you need further assistance, please contact us at help@xendit.ph

Thank you for your understanding and cooperation.

Regards,

Xendit Customer Support
Posted Jun 20, 2022 - 08:47 WIB