Payouts Disruption in Thailand

Incident Report for Xendit

Resolved

This incident has been resolved.
Posted Mar 22, 2025 - 05:20 WIB

Identified

Dear valued customers,

We are currently seeing delays in processing Payouts to the following THB destinations due to system issues with our partner.

TH_SCB: All amount
Posted Mar 22, 2025 - 03:40 WIB
This incident affected: Thailand - Payouts (TH All Destinations).