Increase in Phising emails

Incident Report for Xendit

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 08:57 WIB

Monitoring

Dear Valued Customers,

We have noticed an increase in Phising attempts sent to merchant emails.

Please do not click on links sent through emails.
Please double check the sender of the emails.

Additional security steps such as enabling 2FA are also recommended.

Best Regards,
Xendit Customer Success
Posted Apr 28, 2025 - 10:33 WIB