Delayed Processing in PH Disbursements for amount <= PHP 50K
Incident Report for Xendit
Resolved
This incident has been resolved.
Posted Mar 16, 2023 - 19:46 WIB
Update
We are continuing to investigate this issue.
Posted Mar 16, 2023 - 16:05 WIB
Investigating
Dear Valued Customers,

We are detecting delayed disbursements to Philippines destinations.

Impact:
- All disbursements, withdrawals, and remittances with amounts less than or equal to PHP 50,000 will be delayed until the issue is resolved.
- No impact for transactions with amounts more than PHP 50,000.

We are working with our partners to investigate the issue and will share more details when we have one.
Please refrain from transacting with amounts less than or equal to 50k PHP in the meantime. There is no impact on transactions of more than 50k PHP.

We deeply apologize for the inconvenience and the sudden announcement.
If you need further assistance, please contact us at help@xendit.ph.

Thank you for your understanding and cooperation.

Regards,
Xendit Customer Success
Posted Mar 16, 2023 - 15:28 WIB
This incident affected: Dashboard (Dashboard Withdrawals, Autowithdrawal) and Philippines - Payouts (Disbursement - Other Philippines banks and E-Wallets).